Maserati Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1,067 Posts
Discussion Starter #1
I mean I haven't seen a post from him in a month or so!!! What's going on there Troesma?
 

·
Registered
Joined
·
1,067 Posts
Discussion Starter #4
I sent him an email.....

But haven't heard back yet...
 

·
Registered
Joined
·
660 Posts
Hey guys..!

Yep I'm here, alive and well but tired as hell as it's been a deluge of work for the past 5-6 weeks (with my butt on planes, literally) so that's I've been in dissappeared mode. Thanks Mark, Ali, Peter... all for your concern as to my thereabouts...! Still this side of the earth surface, if you see what I mean... :D

Peter is right I'm in the middle of working on a new project in the marketing analytics arena... so it's been hard work, but things are getting together nicely. Hopefully, after a conference paper I'm presenting next week in Madrid and a likely 2-week tour around SEA, I'll be back to my bed for a change...

The Maser has been a sitting duck since. To the point that the OEM battery went completely dead, purchased an Optima which I installed 1 week later during a 2-day sprint around London, the car then went unusued for another 3 weeks, and last week-end (I was around for Easter) had a go at it and guess... dead... well, not quite dead (voltmeter reading 11V) but no cranking... pressed the start button and nothing, nada... not even a puff. So I'll see wassup tomorrow, before I go out again on Tuesday. Cannot hook a CTek or similar battery conditioner as I have no power near the driveway. Piss.

It never happened with the 4200 (Optima-fitted and at times sitting for 3+ weeks) but there is a great difference now: the GS has a GPS tracker installed. So despite the fact that I left the car with the alarm disengaged, that sucker is killing the battery. Or maybe (but hope not) I have a leak to ground on the wire harness, somewhere. Will see tomorrow.

FD brake pads arrived this week, so on return they will be fitted.

Cheers to all..! ;)

Ed
 

·
Registered
Joined
·
1,685 Posts
Hey guys..!

Yep I'm here, alive and well but tired as hell as it's been a deluge of work for the past 5-6 weeks (with my butt on planes, literally) so that's I've been in dissappeared mode. Thanks Mark, Ali, Peter... all for your concern as to my thereabouts...! Still this side of the earth surface, if you see what I mean... :D

Peter is right I'm in the middle of working on a new project in the marketing analytics arena... so it's been hard work, but things are getting together nicely. Hopefully, after a conference paper I'm presenting next week in Madrid and a likely 2-week tour around SEA, I'll be back to my bed for a change...

The Maser has been a sitting duck since. To the point that the OEM battery went completely dead, purchased an Optima which I installed 1 week later during a 2-day sprint around London, the car then went unusued for another 3 weeks, and last week-end (I was around for Easter) had a go at it and guess... dead... well, not quite dead (voltmeter reading 11V) but no cranking... pressed the start button and nothing, nada... not even a puff. So I'll see wassup tomorrow, before I go out again on Tuesday. Cannot hook a CTek or similar battery conditioner as I have no power near the driveway. Piss.

It never happened with the 4200 (Optima-fitted and at times sitting for 3+ weeks) but there is a great difference now: the GS has a GPS tracker installed. So despite the fact that I left the car with the alarm disengaged, that sucker is killing the battery. Or maybe (but hope not) I have a leak to ground on the wire harness, somewhere. Will see tomorrow.

FD brake pads arrived this week, so on return they will be fitted.

Cheers to all..! ;)

Ed
Ed's alive!!!! Twist that battery kill switch when not in use. Works wonders. When are you going to be in Dallas anyway?
 

·
Registered
Joined
·
660 Posts
Ed's alive!!!! Twist that battery kill switch when not in use. Works wonders. When are you going to be in Dallas anyway?
Hey Buzz..!

Yep, I know, I know... but let me tell you something. It was a false negative..!

Yesterday I drove my other wife car near to the Maser, ready for a jump-start. Opened the Maser trunk, and dunno why decided to pick-up my multimeter just to check it out before connecting the cables. Took a read. OK, 12.05V (so the dash voltmeter was NOT lying) so it's effectively on the low-12s, not surprising after 3 weeks in the shade. Without much hopes, decide to give it another go.

BTW the Optima should have 12.8V fully-charged, so it's been what, about .05V draw/day on average. Alarm disengaged but tracker on, surely that's the reason.

So I jump into the car, turn ignition key and press start... oh my... it spins with no effort. WTF..? The other day I was smashing at the start button and nada, nothing, zip. Leave the engine running and measure again. Steady 14.5V so the alternator is working fine.

What I did notice was that there was a bit of condensation on a plastic bag carrier which I left on the trunk. Given what the weather has been around here, again not unsurprising. Check for leaks (dampness) near the seals... nothing. Check on the battery bay and nothing. Then I wonder. What about the ECU box..? What if condensation built-in there and the day that I tested it simply made it to fart, again..?

I'm going to do a volt-drop test today, pos to earth (check the starter is getting enough juice) and neg to earth (check for leakage). Any reading above 1V and I would be worried. It was just too dark yesterday to bother.

I will also measure the battery today at idle and see if it has recharged properly.

What a piss... but so far the Optima RT delivered. It started yesterday after 3 weeks... agree with a fart in-between, but unlikely caused by the battery.

Will post results tonite before I go on tour again :D
 

·
Banned
Joined
·
1 Posts
It never happened with the 4200 (Optima-fitted and at times sitting for 3+ weeks) but there is a great difference now: the GS has a GPS tracker installed. So despite the fact that I left the car with the alarm disengaged, that sucker is killing the battery. Or maybe (but hope not) I have a leak to ground on the wire harness, somewhere. Will see tomorrow.
 
1 - 8 of 8 Posts
Top