Maserati Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
I have an 06 GS Spyder and out of the blue the up shift doesn't seem to engage as fast, it almost seems like I need to pull the paddle all the way back harder than normal. Sometimes it doesn't seem to engage and I have to hit the paddle twice.

Anyone expereince this problem, any thoughts?
 

·
Registered
Joined
·
3,309 Posts
make sure that you haven't turned off sport mode. Recently, I experienced some of the same problems & was dreading that something was wrong only to find that sport mode (which usually was my default setting at startup) was turned off. As soon as I pressed the button, all returned to normal....
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #6 ·
Thanks for your reply's I drove the car this weekend and it seemed to be back to normal. It wasn't in snow mode or auto (I rather walk) than drive the car in those modes, when it was happening. Down shift always was responsive. Hopefully its all good.

Thanks
 

·
Registered
2006 Gransport LE
Joined
·
662 Posts
I have an 06 GS Spyder and out of the blue the up shift doesn't seem to engage as fast, it almost seems like I need to pull the paddle all the way back harder than normal. Sometimes it doesn't seem to engage and I have to hit the paddle twice.

Anyone expereince this problem, any thoughts?
I had the same thing last week and then I started to pay attention to the shifts and pulled the lever back firmly. It went away also so I don't know if it was a mechanical issue or me simply being a bit too lazy on the flip.
 

·
Registered
Joined
·
478 Posts
I had a similar, recurring problem a month ago when going from neutral to first, usually at a long light where I'd shift into neutral. Needed repeated pulls on the upshift lever, in some cases I'd actually have to put the car into reverse to get some engagement, then into first. SW upgrade at the dealer took care of that and I got quicker up & down shifts as well.
 
1 - 8 of 8 Posts
Top