Maserati Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1
Is there a way to turn off the max defrost on a Gransport? I inagine it's on because of the indicator light.

My windshield fogs but I dont think it's the heater core, no smell and it's on the outside. Wipers get rid of it.

I think/hope I just blowing cold air on the windshield
127697
127698
 

·
Super Moderator
Joined
·
3,821 Posts
Not sure quite how the GS works, but I'd have thought that was off

If the fan is on full blast that'd be a goos sign. SIs it possible it's just a marker light.

In other news, if you try using your aircon (i.e. turn it on by pressing the Econ button and moving the dial to 'Auto' you might well find that your windscreen stops misting. Almost like magic.....

NB Assumes your A/C is working properly.....

C
 

·
Registered
Joined
·
57 Posts
Your fan is probably still on since "ECON" is turned on. And the ECON light "on" means that the AC compressor will not be running but the fan is running and directing air to the vents - upper and lower according to your pic. The small light looking dot below Max Defrost (not related to Homer's Max Power) is not an actual indication of anything as far as I remember. I've had my control board apart and I don't remember a specific light under that dot.

Turn turn the system fully off, set the fan speed to 0 or off. AUT will not turn it completely off. The temperature and vent control can remain on AUT, but the fan speed knob is more of the on/off button for the system.

Mist on the windshield is due to temperature differences and humidity. Is that an sunrise photo? I get misting in the morning occasionally and rarely use the fan/vents in the morning.
 

·
Registered
Joined
·
48 Posts
Discussion Starter #4
Yes, sunrise
It's hot in FL even in the am lol
It does it even during the day.

Econ was not on, if I hit the econ button it actually lights up brighter

I'll keep playing with it. Tried all settings with no luck but glad to hear that indicator light doesn't actually mean anything.
 

·
Registered
Joined
·
1 Posts
When I test drove my '05 before purchase the demister was stuck on exactly like you report. It seemed to be a loose connection in the rotary switch as applying pressure to one side of it would turn it off temporarily. The indicator light was on with the demister with the fan running hard.

I had the dealer fix it before purchase so I don't know what the fix was, sorry.
 
1 - 5 of 5 Posts
Top