Maserati Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
1,067 Posts
Discussion Starter · #1 · (Edited)
So I went out for a drive tonight, wanted to put it down hard...
Anyway, ended up throwing codes and they were P1149 and P1189. The car went into safe mode, nothing over 4k rpm, made it home quite well, when I cleared the codes it ran again fine for about 5 mins then the same codes came up.. I had been running a different fuel ramp, one much leaner for my altitude. Once this problem started I switch back over to the normal fuel ramp..

1. So have any of you had these codes?
2. Looking around on the web it says the HO2 sensor is putting out values out of range.
3. Will I have to replace the sensor or do you think it will be okay after I let the car cool, erase the codes and turn off the battery for a while?

Let me know ASAP..

Thanks,


Mark
 

·
Registered
Joined
·
1,067 Posts
Discussion Starter · #3 · (Edited)

·
Registered
Joined
·
1,067 Posts
Discussion Starter · #4 ·
Fuel...

So last night I drained about 10 gallons out my tank, put it in my Toyota, then went down the station and filled her back up with VPower.. It ran good for about 25 to 30 minutes and then finally threw the codes. I did this with the original CPU settings so it has nothing to do with that, it's just the stupid fuel additive.. I will drain the Maserati tank again by about 10 or 12 gallons here soon, put that in my Toyota, then fill it back up with pure VPower again and soon it should go away..

Whatever you do guys, don't put the NOS octane booster/fuel injector cleaner stuff in your gas, it will wreak havoc on your emissions stuff...

I am just hoping after I get this crap out of my tank that I haven't messed up the sensors and I won't have to replace them...

http://www.westwardeng.com/nos.htm
 

·
Registered
Joined
·
6 Posts
Ali,
I will take it over to the station tonight and fill'er up with Shell VPower.. It's not suppossed to cause a problem but perhaps it does...

Thanks!

BTW, Everyone, here is a good code list..

http://www.kbmsystems.net/obd_fault_codes_ref.htm
http://www.kbmsystems.net/obd_fault_codes_db.htm

P1149 Air/Fuel Ratio (A/F) Sensor (Sensor 1) Range/Performance Problem
P1149 Air/Fuel Ratio Sensor (Sensor 1) Circuit Lean Range
P1189 Pump Speed Signal Fault
THANKS A LOT FOR THIS QUICK REPLY
 
1 - 8 of 8 Posts
Top