Maserati Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I have an 02 coupe with the Nav stereo combination. In the begining the sound started to sporaticaly go out. Eventualy all sound has gone away. The screen looks normal, the CD player is operational and the counter works even the GPS. I do not have the amplifier option. Is the actual Nav unit the amp as well? Is this a common problem? Any input would be appreciated considering the cost for a replacement.
Sincerely
Tom
 

·
Registered
Joined
·
778 Posts
I dont know if Maserati's sound system is the same as my lexus, but here are some things to check. If you are comfortable doing them....

1) remove nav screen and cd player. usually the screen itself should have some fuses close to the wire harnesses. I would check those fuses.

2) check in the trunk for an amp relay. There should be two boxes. one is normally the NAV unit brain, which should have a dvd slot in. The other box should be close by and have cooler fins, that will be the amp. id check all the harnesses, fuses, and last resort have it power tested.

hope that can help you some
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
does anyone know where the amplifier for an 02 coupe is located? and where the amp relay may be located?
 

·
Registered
Joined
·
94 Posts
i believe the amp is on the left side of the trunk, i think under the cd changer.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
I would like to thank everyone for the responses and suggestions. The Maserati guys are quite cool. I own a Lambo, a Lotus, a Ferrari, a Viper and the Maserati of course. Out of all the forums I belong to you guys are quite a great bunch.
The problem was solved. Of all things it was a loose passenger door speaker wire. I guess it uses a closed looped circuit. 6 months i have taken apart that thing every weekend. I would have never guessed. Thats ITALIAN for you.
Problem solved.
Sincerely
Tom Georgalis
 
1 - 7 of 7 Posts
Top