Maserati Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3,309 Posts
Discussion Starter #1
The last two times I've dropped the top on my '06 GS, the process stopped 1/2 way through, just before the rear deck lid raises. Releasing the button and then depressing it again continues the process successfully to completion. Anyone else experience this? Should I try switching the battery off to reset the entire system?
 

·
Registered
Joined
·
722 Posts
Yes, switch off the battery for a minute to see if it figures things out. If that fails, your car probably needs a microswitch adjustment.
 

·
Registered
Joined
·
1,685 Posts
The last two times I've dropped the top on my '06 GS, the process stopped 1/2 way through, just before the rear deck lid raises. Releasing the button and then depressing it again continues the process successfully to completion. Anyone else experience this? Should I try switching the battery off to reset the entire system?
When my top gets stuck half way I get VERY concerned!!!! I drive a coupe! :D
 

·
Registered
Joined
·
722 Posts
Coupe guys miss out on so many things!

I forgot to mention, make sure you know your radio's 4-digit code before switching off the battery.
 

·
Registered
Joined
·
3,309 Posts
Discussion Starter #5
When my top gets stuck half way I get VERY concerned!!!! I drive a coupe! :D
BeeYouZee2 - you scare me....aren't you the guy that nicked both passenger-side rims with your MSP turned off!:D
 

·
Registered
Joined
·
3,309 Posts
Discussion Starter #6
just to close out this thread.....switched battery off, waited a few minutes, switched juice back on.....entered radio code & all back to normal again. Thanks guys for the advice. Good to have the support of this community. ;)
 

·
Registered
Joined
·
722 Posts
No prob, good to know other people who understand why we bought the bugger.
 
1 - 7 of 7 Posts
Top