Maserati Forum banner
41 - 47 of 47 Posts

·
Premium Member
2004 Spyder Cambiocorsa Verde Mistral / Black
Joined
·
90 Posts
2006 spyder, top down and stored, push to raise the roof the lid only opens a few inches stops, repush the up button goes up another few inches and stops, repush button 3 rd time and goes another few inches stops, repush nothing push down nothing, push button in the storage compartment, releases pressure lid drops into place. Some times i have to give a little push while holding up button to get it locked into top down all lights off as per normal.. Turned off the master power switch overnight, left charger on to top up battery, turned power on, reset secret code.....still acts the same with car running, parkbrake on brake pedal pushed......what am I missing????
Thanks for any and all help
Gord
Secret code? Is that tongue-in-cheek or for real? 'Enquiring minds need to know!' ;)
 

·
Registered
Joined
·
47 Posts
I am, trying to read through all the comments on the top not working so please bear with me if I am asking a question that has already been answered. We just purchased a 2004 Spyder and when do all the normal stuff windows up, doors and trunk closed hand brake set and push the top button forward nothing happens, so I am assuming that pushing the button forward is to put the top up, so when I push the button back the windows dont go down and the only things that happens is the very rear portion that the window is in goes up and then it stops and that all that happens. Any assistance would be great and/or send me to threads that discuss how to fix my issues. Thanks in advance!!
 

·
Registered
Joined
·
2 Posts
Hello, I have here a maserati spyder aswell, the top didn't open, the windows will go down, latches begin to open at the back after they are open the hydraulic pump starts but doesn't seem to build pressure.

I have checked everything, it looks really like the only issue is that the pump can't build up pressurre.
I have opened the pump, the oil was a bit dirty, but apart that nothing realy to find, i hoped with new oil it works but after fitting it's the same problem.

The valves work, because only when i push the button to open the top, you can move it, otherwise it's stuck because you can't move the oil in the pistons.

Or maybe 1 valve stays in the wrong position causing the pressure to escape there
If i test all valves, the seem to be working

Is there a way to bleed the system?


(the relief valve is closed)
 

·
Registered
Joined
·
628 Posts
I am, trying to read through all the comments on the top not working so please bear with me if I am asking a question that has already been answered. We just purchased a 2004 Spyder and when do all the normal stuff windows up, doors and trunk closed hand brake set and push the top button forward nothing happens, so I am assuming that pushing the button forward is to put the top up, so when I push the button back the windows dont go down and the only things that happens is the very rear portion that the window is in goes up and then it stops and that all that happens. Any assistance would be great and/or send me to threads that discuss how to fix my issues. Thanks in advance!!
Engine running? You can put the windows down manually and then start the top lowering process.
 

·
Registered
Joined
·
2 Posts
Hello,

Yes engine running, the windows go down with the top button, then the latches at the back go lose then the hydraulic pump begins but makes no pressure.
I have it open again, and removed the valve block, the pump does give some flow but i can easily block it, i don't feel any pressure.
I have it again completely open but can't realy understand how it must build pressure because it's also connected to the reservoir where i have a bit flow.
There is some 'valve' with a spring on the bottom, i removed it but i don't know how it works.

Flow comes out 2 ports, 1 is for return i think. These 2 ports are connected to the pressure ports of the pump rotor axe, but they also go to this valve with spring where there is a filter.

I was thinking of finding an overpressure relief valve, but can't find it, if that one is leaking always you also have no pressure, only some flow.

it's strange to me, but must be solvable
 

·
Registered
Joined
·
20 Posts
My top in Maserati Spyder stopped operating before it got completely closed, no power or sound from hydraulics, I’m trying to check the fuses, I know it’s 17 and 18 in Fuse box P in the trunk, battery compartment.. I spent three hours looking And I can’t find the freaking thing ( I can see fuse boxes M and N ). could someone please post a picture or tell me exactly where to look for Fuse box P or how does it look? Do I need to remove trunk side panels to get access to it near the battery?

Thank you so much, Alex
 
41 - 47 of 47 Posts
Top