Maserati Forum banner
21 - 40 of 47 Posts

·
Registered
Joined
·
72 Posts
Anyone know the location of the convertible top hydraulic pump fuse or relay? I turned the screw in the white cone behind passengers seat to the left trying to diagnose my top problem. After resetting battery and other troubleshooting, my pump won’t kick on and pressurize the lines.
This thread might help.
 

·
Registered
Joined
·
35 Posts
Thanks tony. I checked P. And all fuses test well. Can’t figure out why my hydraulic pump isn’t working. Might have to take everything apart.

Top light is on in the cluster And will blink. I also removed the top switch and tested it. Even put jumper wires to the pigtail without top switch plugged in. Still nothing.
 

·
Registered
Joined
·
628 Posts
Thanks tony. I checked P. And all fuses test well. Can’t figure out why my hydraulic pump isn’t working. Might have to take everything apart.

Top light is on in the cluster And will blink. I also removed the top switch and tested it. Even put jumper wires to the pigtail without top switch plugged in. Still nothing.
The system uses limit switches to sequence the steps so if it's part way in a sequence it may not know what to do. Is your top in the fully, and I mean fully, in either the up or down position?
 

·
Registered
Joined
·
628 Posts
From Owner's Manual

The top opening or closing procedure
is admissible only if all of the following
conditions occur:
1) Vehicle stationary with handbrake
engaged.
2) Engine and luggage compartment
lids completely closed.
3) Ignition key in the MAR position.
4) Windows fully up.

If you need it repaired take it to a convertible top expert, definitely not a dealership.
 

·
Registered
Joined
·
628 Posts
If the top is fully up and properly latched, then the first step in putting the top down is to undo the pull down latches at the back of the top. This happens before the pump starts. There is a limit switch(s) on the pull downs so that's where I'd look first. To do that you'll have to put the top down manually which would involve undoing the bolts that hold the pull downs to the top.

Once you get the top down I'd do a reset and try to put the top UP. In this sequence the latches operate last but if they've failed this might still not work.

Upside down picture. LS on left. They have a fuse.

136746
 

·
Registered
Joined
·
35 Posts
Thanks Tony. I got the top manually all the way open. Took a bit of haggling. Then I reset The battery and it went up except for the last step. I had to reinstall the rear pull downs on the back of the top and it bacame snug. The issue is i think the break in the sequence to reinstall pull downs caused it to lose sequence again. So I’ll do a take two and see what happens. Btw. Top latches At windshield came undone. A little penetrating oil on the latches loosened it up.
 

·
Registered
Joined
·
46 Posts
If the top is fully up and properly latched, then the first step in putting the top down is to undo the pull down latches at the back of the top. This happens before the pump starts. There is a limit switch(s) on the pull downs so that's where I'd look first. To do that you'll have to put the top down manually which would involve undoing the bolts that hold the pull downs to the top.

Once you get the top down I'd do a reset and try to put the top UP. In this sequence the latches operate last but if they've failed this might still not work.

Upside down picture. LS on left. They have a fuse.

View attachment 136746
Hi Tony
where are the bolts that hold the pull down located?
thanks
 

·
Registered
Joined
·
4 Posts
I see the OP has gone silent after I asked a few questions, so for the rest of us here's some more info. The manual procedure in the owner's manual is to put the top UP. To put the top down you can't undo the latches at the back of the top using the switch. There is a previous post where the poster and I discussed what could be done. So to put the top down you need a 10 mm socket and a long extension to undo the 4 bolts on the hold-downs from inside the car. You can then do the rest of the procedure.
Where are the 4 bolts located to Free up the hold-downs?
 

·
Registered
Joined
·
31 Posts
2006 spyder, top down and stored, push to raise the roof the lid only opens a few inches stops, repush the up button goes up another few inches and stops, repush button 3 rd time and goes another few inches stops, repush nothing push down nothing, push button in the storage compartment, releases pressure lid drops into place. Some times i have to give a little push while holding up button to get it locked into top down all lights off as per normal.. Turned off the master power switch overnight, left charger on to top up battery, turned power on, reset secret code.....still acts the same with car running, parkbrake on brake pedal pushed......what am I missing????
Thanks for any and all help
Gord
 

·
Registered
Joined
·
31 Posts
2006 spyder, top down and stored, push to raise the roof the lid only opens a few inches stops, repush the up button goes up another few inches and stops, repush button 3 rd time and goes another few inches stops, repush nothing push down nothing, push button in the storage compartment, releases pressure lid drops into place. Some times i have to give a little push while holding up button to get it locked into top down all lights off as per normal.. Turned off the master power switch overnight, left charger on to top up battery, turned power on, reset secret code.....still acts the same with car running, parkbrake on brake pedal pushed......what am I missing????
Thanks for any and all help
Gord
OK, so the lid is going all the way up after 3 pushes...then nothing
 
21 - 40 of 47 Posts
Top