Maserati Forum banner
1 - 19 of 19 Posts

·
Registered
2016 GranTurismo Sport Rosso Mondiale
Joined
·
1,283 Posts
Discussion Starter · #1 ·
Ok folks - I normally don't ask for help too too often but could use it....

Had my 2016 new since dealer.....never have had a major issue (other than TPMS and such).

So yesterday while driving after 5 years got the dreaded check engine light on.....

Figured would check the gas cap trick....hasn't seemed to fix the light (yet at least).
Restarted 10 times over 2 hours....hasn't seemed to fix the light (yet at least)

So I pull out my handy dandy scan tool (MaxAP AP200) - thank you forum. (I believe downloaded all the apps and guides correctly after install - I selected GranTurismo Convertible as no other real close option)

It appears as though I am getting this fault:

P2189 = LH Main bearing mixture adding ratio self-teaching (mixture too lean)-S.C. VBAT - over Max threshold

I mean is that a gas cap issue? Something more serious? Should I wait on the gas cap tighten trick and see if it goes away?


Rectangle Grey Font Screenshot Parallel
Rectangle Grey Font Screenshot Parallel
 

·
Registered
Joined
·
4,469 Posts
Have you done any work on the car recently? Does the engine still run smooth? Code sounds like a possible vacuum leak somewhere. You said you checked the gas cap, any chance you can actually test it?
I would make sure my oil cap is snug too and check for any obvious vacuum leaks around the engine...maybe even introduce some smoke. If the car is running normal, I would keep driving it. Sometimes it takes a few days for the check engine light to go out, if it is indeed the fuel cap. Good luck though.
 

·
Registered
2016 GranTurismo Sport Rosso Mondiale
Joined
·
1,283 Posts
Discussion Starter · #3 ·
Zero work done. Last fall 2021 did oil change and only 3,000 miles since then.
I will drive it around a bit with the gas cap recently tightened (it was NOT loose BTW, but I know it can be a common issue so I took it off and rechecked it anyways.)

I will keep driving it....I just didn't know if that error was familiar to anyone.
 

·
Registered
Joined
·
4,469 Posts
Zero work done. Last fall 2021 did oil change and only 3,000 miles since then.
I will drive it around a bit with the gas cap recently tightened (it was NOT loose BTW, but I know it can be a common issue so I took it off and rechecked it anyways.)

I will keep driving it....I just didn't know if that error was familiar to anyone.
Personally haven't seen this one before, hopefully someone has or one of the resident experts will chime in. (y)
 

·
Registered
2012 GTC Nero/Sabbia
Joined
·
557 Posts
I had the 2189 code after swapping the filter and not tightening the clamps well enough and also not inserting the small hose on the right deep enough - once I got that done the problem was sorted...
 

·
Registered
2016 GranTurismo Sport Rosso Mondiale
Joined
·
1,283 Posts
Discussion Starter · #7 ·
Jason,
I always remember your phrase "that's like trying to give a haircut over the internet" when trying to diagnose a problem remotely...so I am careful to ask....hahahah, but three quick questions:

Since I do not know what a "vacuum leak" is...(I have zero automotive technical skill)
#1 Is it safe to continue driving for a while?
#2 Since I have no local Maserati dealer within 3 hours (I just got to a local independent) - would they be able to figure it out?
#3 How bad ($$$$) is a "vacuum leak" ?
 
Joined
·
7,622 Posts
I'm glad you remember that...lol...It is so true...Your local place should be able to handle something like that...These older cars are not NASA stuff tech.. wise...Jason
 

·
Registered
2016 GranTurismo Sport Rosso Mondiale
Joined
·
1,283 Posts
Discussion Starter · #9 ·
So Jason I am gonna push my luck with the "haircut over the internet" comment.....

Can you please answer the three questions I posted above?

Well at least #1 & #3
 

·
Premium Member
2013 GTS Coupe
Joined
·
4,910 Posts
If the leak is in one of the vacuum lines / hoses , in some cases a smoke test might detect it . The shop should be able to do that .
My MBZ had a small leak in a hose which set off a CEL, but the car also had some rough idle symptoms at cold starts .

Or as noted in the above posts , if it’s the gas cap it may take more than a day or two of driving it to resolve the reading which triggers the CEL.

Could also be a gasket ( the intake manifold one ) but doubtful that’s likely . A failing evap system valve ( ECR ? ..can’t remember what those are called ) could trigger the CEL, but I’d think that’s also a low probability, as well. I’m told that 80% of CELs are triggered by emissions related problems, but clearly there are others..

I’d suggest a smoke test, should be cheap and quick. If it turns out to be a hose with a loosened clamp , or even a crack in it, if it’s easily accessible to replace it should be quite inexpensive..
Cant imagine there is a problem driving a little while with the CEL on ( absent any serious symptoms ) just as long as you don’t test your fate and take the rpm to the redline , but I could be wrong so best rely on Jason’s response to that ..
 

·
Registered
2016 GranTurismo Sport Rosso Mondiale
Joined
·
1,283 Posts
Discussion Starter · #11 ·
OK soooooooo update......Last week Check engine light came on....did the Gas cap cover tighten trick....scan tool....light was still on ect.... well I drive for a few days +/- 200 miles and POOF - light is OFF.....so was it the gas cap issue? No idea but heck I will take it....for the life of me I have never changed how I put a gas cap on Hahahha.
 

·
Registered
Joined
·
4,469 Posts
OK soooooooo update......Last week Check engine light came on....did the Gas cap cover tighten trick....scan tool....light was still on ect.... well I drive for a few days +/- 200 miles and POOF - light is OFF.....so was it the gas cap issue? No idea but heck I will take it....for the life of me I have never changed how I put a gas cap on Hahahha.
Glad it sorted itself, like we said, keep on driving brother. :p
 

·
Premium Member
Joined
·
62 Posts
I hope it stays off for you, Tasnam.

For whatever this is worth ... we owned a 2006 Lexus GX 470 for some 16 years until the frame rusted out this Spring (Chicago DD). Last year, I had a CEL and a traction control light (I think) come on at the same time. The Lexus dealer had a good hunch immediately what the problem was - a leak in the gas filler neck and/or gas cap itself. Yes, the cap was always screwed on tight. I don't remember the explanation given to me why the TC light came on too, but the dealer's explanation made sense to me at the time. The repair was about $175 as I recall.
 

·
Registered
2012 GTC Nero/Sabbia
Joined
·
557 Posts
I have to say that after my recent air filter replacement my car is running like crap. I had no less than 4 or 5 Check Engine lights, all to do with poor mixture at idle, only at idle. On top of that when the car runs when I am stopped at a light the RPM fluctuates between 550 and 700 rpm at times feeling like the engine is either suffocating or it is going to stall. It doesn't obviously but it does feed the paranoia very well.

Could a filter be that bad or is it something else?
 
Joined
·
7,622 Posts
2 things...Not a fan of any kind of oil type filter...The oil tends to mess up the mass air flow sensors...That is why the factory uses paper...You need to make sure the boot is on correctly and little hose on the side is connected correctly...Jason
 

·
Registered
2012 GTC Nero/Sabbia
Joined
·
557 Posts
2 things...Not a fan of any kind of oil type filter...The oil tends to mess up the mass air flow sensors...That is why the factory uses paper...You need to make sure the boot is on correctly and little hose on the side is connected correctly...Jason
The little hose on the side is what concerns me - I am not really sure how far in it needs to be pushed in. The filter is just a standard paper filter not the oil type.
 
1 - 19 of 19 Posts
Top