Maserati Forum banner

1 - 13 of 13 Posts

·
Registered
Maserati GTS 2014
Joined
·
6 Posts
Discussion Starter #1
My car is 14 GTS and he is weird.
133240
The suspension light showed up and disappeared again and again. The first time I had this light on was 2018. I took the car to dealer and they said nothing was wrong. This light didn’t show up until 2019. I went to several local shops and they said nothing wrong with the machines. Sometimes when the light popped up, I just restarted the engine then this light would go off. This time is tough, the light came back again and I couldn’t get rid of it. I went to friend’s shop to check. The engineer told me that every physical parts are good but the skyhook suspension ECU is broken. It took 1700 to change the ECU included labor. I never drive crazy before. Although I felt bumps when driving with this light on, the engineer told me I can still drive it with this light. It just makes the suspension harder. So...my dear community, what should I do? I need suggestions plz:)))))
 

·
Super Moderator
Joined
·
4,755 Posts
Have you taken it to a Maserati expert?

C
 

·
Registered
Joined
·
402 Posts
So the light is still on with the new ecu? Is your shop able to scan for faults?
One thing you could do is try a battery reset.
 

·
Registered
Joined
·
310 Posts
You didn't say whether the faults were actually cleared by a scanner. They will go away after a restart but then come back later.
After I cleared mine with a scanner, they did not return. I agree about the battery charge issue and even "new" batteries can sometimes be faulty and not hold a fully charge.
 

·
Registered
Maserati GTS 2014
Joined
·
6 Posts
Discussion Starter #11
Yes the scanner said the skyhook suspension computer is dead. I have cleared the code before but still return😿
 

·
Registered
Joined
·
116 Posts
Hello @SkyhookError
We would like to hear more about your concerns to determine how we may assist. Please send us a private message with your VIN so that we can investigate further.

MaseratiCares
 

·
Registered
Joined
·
91 Posts
Hello,

I have the same issue. With my AUTEL, I saw before reset 2 defaults : C1161 and U1706.
I don't know if u have the same error code.

It's not the battery. I changed it but I had recently the issue.
 
1 - 13 of 13 Posts
Top