Maserati Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
338 Posts
Discussion Starter · #1 ·
Hey all...

Ok... real wierd.

Hard to explain - but get out of the car and the door seems to want to "self lock."

Like I open the door and door (while open - the door tries to lock itself).

It stops after a while or if I close my door - it proceeds to self lock.

And even if I use the key remote. The first push - the car blinks - but it doesn't open.

Then I open it with the key (and not remote - and it works - but this is just messing me up.

Also...

It started when for some reason - like hit the remote to open the door while like the trunk was open or something like that.

So I started to drive - and the red light by the gear numbers started to blink.

Almost like I started the car and the security though it was stolen or something???

So I stop the car, get out and the get back in again to I guess "reset" the alarm?

Hope I made a lick of sense here.

Can anyone help?

Gene
 

·
Registered
Joined
·
1,067 Posts
Get out of the car. Lock the doors. Open the trunk with the remote, turn the battery switch off for 1 minute, then turn it on again.. Let me know what happens...
 

·
Registered
Joined
·
50 Posts
I had the same Issue 4 weeks ago, it happened once and never again.

I thought it's because of the sudden temp. drop that something in the door just froze.

let me know the out come of your diagnostic please.
 

·
Registered
Joined
·
338 Posts
Discussion Starter · #7 ·
Ram,

Car is in my garage right now.

I just used the remote to lock the door and so far it's good.

Tomorrow, I will check it out and hopefully it will work.

It IS very cold right now.

And waiting for Grand to reply to my last post.

Nice to know it's not just me.

Gene
 

·
Registered
Joined
·
3,309 Posts
Gene - I have pretty much the same problem best I can tell. I tried GrandLake's suggestion and it didn't work for me. However, I think my situation is a bit more problematic.

FYI - the battery switch is a round knob that sits just above and in front of your battery. You turn it to disconnect power. Pretty sure that's what GrandLake was referring to....It's weird but, it seems that there has been a sudden rash of this type problem in the last month on this board. Wonder if it's temperature related?
 

·
Registered
Joined
·
338 Posts
Discussion Starter · #9 ·
Wow...

This sucks.

I tried it again this morning and it's the same thing.

I even tried Grand's trick.

I now have a self locking car.

Even when I use the key - as soon as I unlock - it want's to relock.

So I have to open the door fast.

I guess I have to take it in.

Gene
 

·
Registered
Joined
·
338 Posts
Discussion Starter · #10 ·
Ok... still have the problem - now it's the opposite. Because I opened it manually through the passenger side - now the car insta-opens.

I can't lock it.

So I posted on the other thread by 04MAS and hope he has some answers to me.

He got it fixed with some bad motor.

Gene
 

·
Registered
Joined
·
338 Posts
Discussion Starter · #11 ·
Ok...

If anyone is following the this thread...

So I made an appointment yesterday to go to the Mas Dealership to get this fixed.

But this morning - the temperature outside is 70 degrees.

And low and behold - it's working again.

Granted - it probably still needs to be fixed - because the locks get "sticky."

But it seems it's not the motor.

This is what I think is going on.

Either:

A) as some of you suggested - the locks are not real smooth to begin with and they get caught half way or they stick.

B) The extreme temperature drop and rise causes condensation on the motor temporarily causing the motor to fail.

That is why some of you reported the same problem and then it just fixed itself.

If my passenger lock motor was broken - it wouldn't have fixed itself.

But the weather went from 70 degrees here outside to about 35 degrees in almost a day - and then it shot back up.

I think somehow that is the problem.

Also... by the way... this is crap.

Does Maserati read these boards? Is anyone there doing any research?

Like most of you here, my Mas is not my everyday car.

Actually I drive it around town a lot - but at best - I'm putting 90 miles on it a week.

But the amount of electrical problems I've had with this car is incredible.

I can't imagine it would be like if I was driving it 400 miles a week like I do my Lexus.

Gene
 

·
Registered
Joined
·
1,405 Posts
I'm having kinda same problem with my car. It won't lock. Actually, as I press the remote it locks and then instantly unlocks. If the door is open when I press the remote, the lock would lock/unlock several times.

Anybody has any idea what it is?

Thank you in advance!
 

·
Registered
Joined
·
104 Posts
I'm having kinda same problem with my car. It won't lock. Actually, as I press the remote it locks and then instantly unlocks. If the door is open when I press the remote, the lock would lock/unlock several times.

Anybody has any idea what it is?

Thank you in advance!
I had that exact thing and the dealer had to change out the power door lock on that side. I think they get all gummed up and don't work anymore.

JJ
 

·
Registered
Joined
·
50 Posts
reactivate alarm !!

I had the same issue with my door locks, the passenger side door lock gums up from time to time specially in winter because of the freezing temps. The driver door will start acting up when that happens and auto lock every time I open the car using the key remote.

so I was opening the car manually with the key from the passenger side for a while. yesterday I tried the key remote again and it’s working .

now here is the new issue. the car is locking and unlocking normally with the key remote , the car is blinking when doors are locked (normal) ..

BUT the red LED in the dashboard is not going on and the car is not activating the alarm !! so with the roof down I can lock the car and open the door from inside with no alarm going on at all!!!!!!!!!

I tried shutting off the battery for a couple of min but nothing changed.

Anyone knows how I can reactivate my alarm ???

thanks,

RC
 

·
Registered
Joined
·
338 Posts
Discussion Starter · #15 ·
Ram...

Currently I'm turning off my battery every time I'm away from my car more than 3 days.

Basically, if I'm leaving the car in the garage more than 3 days - I' just go ahead and turn off the battery.

When I turn it back on? I have to hit the remote and turn off the alarm OFF before I get it to the car.

So basically. Every time I shut off the battery and turn it back on - the alarm re-sets.

Thoughts?

Gene
 
1 - 15 of 15 Posts
Top