Maserati Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi Guys,

I need help with 2 questions please, from the start the steering control wasn't working Maserati granturismo S 2016.
I installed new Android apple carplay system and still facing same issue although all the setting are configured.
also, getting a message on the main screen " 20 M " that won't disappear.

attached two photos.

Thanks for help !!!
 

Attachments

·
Premium Member
2013 Maserati Granturismo
Joined
·
1,117 Posts
That is an odd head unit, Different from the AuCar and the AcarNavi, I could of helped you but not sure what kind of head unit you have. You are facing canbus issues, Probably need to contact the manufacturer of the head unit.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
That is an odd head unit, Different from the AuCar and the AcarNavi, I could of helped you but not sure what kind of head unit you have. You are facing canbus issues, Probably need to contact the manufacturer of the head unit.
Hi,

Thanks for replay ! actually i don't think its canbus issue because when i do open the doors, and move the gear stick to " R " both activities shown on the screen.
what does mean head unit ?

Thanks !
 

·
Super Moderator
Joined
·
5,596 Posts
Just because one part of the CANBUS is working doesn't mean all the nodes are talking to each other....

You also appear to have an immobiliser issue. Does the car start?

C
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
Just because one part of the CANBUS is working doesn't mean all the nodes are talking to each other....

You also appear to have an immobiliser issue. Does the car start?

C
Hi, Yes the car starts and everything fine expect this error message on main screen " 20 m " and the steering wheel controls not working.
Btw, also on the original one it wasn't working ( sometimes it was working ) but mostly not.
 
1 - 7 of 7 Posts
Top