Maserati Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
So I have a 2011 QPS just under 60k miles and recently starting getting the Check Suspension which comes on randomly and sometimes not at all. And then suddenly as well my TPMS error has appeared then disappeared, both sometimes seem to come on after a harder braking instance. Sometimes the Check Suspension comes on after shifting into reverse, sometimes after speed bumps, sometimes right after turning the car on. I am not noticing any handling differences though. Battery while running is between 13.6-13.9 volts with A/C and radio on. I assume its one of fun Italian gremlins but thought I would reach out to the collective knowledge group.

Thank you all for any insights,
Tony
 

·
Super Moderator
Joined
·
4,755 Posts
Can't see why there would be unless there's a loose connection / mount.

C
 
  • Like
Reactions: arbasica

·
Registered
Joined
·
659 Posts
the main connection is that they are both under the driver carpet, there is an access door under the floor mat.
water infiltration and built up condensation in the area from wet shoes and rain can lead to corrosion in the connector/terminals.
 

·
Super Moderator
Joined
·
4,755 Posts
the main connection is that they are both under the driver carpet, there is an access door under the floor mat.
water infiltration and built up condensation in the area from wet shoes and rain can lead to corrosion in the connector/terminals.
Good shout!

C
 

·
Registered
Joined
·
201 Posts
I had the suspension light warning come on intermittently before my alternator went bad, I swapped it out with a new one and it has not ever come up since. I do have the TPMS issue now, checked all 4 sensors (good batteries on all 4) so now going to play around with ECU. I'll update you with what I find.
 
1 - 6 of 6 Posts
Top