Maserati Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
753 Posts
Discussion Starter #1
Hey all looking to clear a few active codes on the most recent scan of my 07 QP Auto

#1 is C1203 which is "REAR RIGHT-HAND SOLENOID VALVE - Minimum threshold exceeded"

I believe its a suspension control module failure that manifests itself as this particular code based on searches of this forum. It comes up after about an hour of driving, and will go away on a restart, but will appear more frequently once it has appeared initially. The car will default to full hard damper settings and issue a warning to go to the dealer. I will check wiring before anything else but I wanted to see if anyone else had insight with this issue.

#2 is B1033 "SEAT TEMPERATURE PROBE - INVALID SIGNAL"

The seat heater seems to work fine and I dont think anything is unplugged under there but I'll have to confirm. Again, looking to see if anyone has specific knowledge of where or what to look for. I know the car has had some sticky button work on it, as well as some stitching repaired, so I can assume some of the interior has been apart at some time.

#3 is B1017 "RELE RISCALDAMENTO SEDILE O CABLAGGIO RISC. - NO ADDITIONAL INFO FOR THIS DTC"

You got me on this one, I translate it to mean "RISC HEADLIGHT RISK HEATING RELAY" but I dont know much else. Headlights seem to work fine and all functions normal otherwise.

Thanks in advance! I'll be able to scan the car again in the future but I'd like to be able to have zero codes this time :)



 

·
Registered
Joined
·
753 Posts
Discussion Starter #4
hi did you sort out the suspension error, thanks
Yup, I was dead on with that one. It was a bad computer.

Sent from my XT1585 using Tapatalk
 

·
Registered
Joined
·
2 Posts
Hi TwinTrbo
I have just got this :"#1 is C1203 which is "REAR RIGHT-HAND SOLENOID VALVE - Minimum threshold exceeded"

I see about you said above about it being being a bad computer, what part was bad ?
Thanks in advance for any help 🙂
 

·
Registered
Joined
·
753 Posts
Discussion Starter #7 (Edited)
For Raptor and TopCat, as I already said, it was the main ecu that failed. It's located under the Driver (Left side) floor board.

Sent from my SM-G960U1 using Tapatalk
 

·
Registered
Joined
·
2 Posts
For Raptor and TopCat, as I already said, it was the main ecu that failed. It's located under the Driver (Left side) floor board.

Sent from my SM-G960U1 using Tapatalk
Thanks for replying, I will have to see how to get another one :(
 
1 - 9 of 9 Posts
Top