Maserati Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
160 Posts
Discussion Starter · #1 ·
I did some searching and didn't see anything similar, so figured I'd see if anyone else had this problem.


2018 GT.. I programmed the Homelink and it worked for a bit, but now it's not working. I get 0 lights from pushing the buttons. I've also noticed that neither of the lights in the vanity mirrors work either. Presuming it may be a fuse issue, but couldn't locate the fuse in the manual. I will be taking her in for the Airbag recall, but figured I'd ask here ahead of time. No other electrical issues that I can see, and I did have her on a tender recently.


TIA!
 

·
Registered
Joined
·
3 Posts
I did some searching and didn't see anything similar, so figured I'd see if anyone else had this problem.


2018 GT.. I programmed the Homelink and it worked for a bit, but now it's not working. I get 0 lights from pushing the buttons. I've also noticed that neither of the lights in the vanity mirrors work either. Presuming it may be a fuse issue, but couldn't locate the fuse in the manual. I will be taking her in for the Airbag recall, but figured I'd ask here ahead of time. No other electrical issues that I can see, and I did have her on a tender recently.


TIA!
Did you ever find out what was causing this? I have the same issue. thanks
 
Joined
·
7,399 Posts
I honestly don't reply when people jump on old post...I not sorting through all that to figure out what they have going on...The confusion is not worth my time...1st time poster on a 2 year old thread...No thanks...Jason
 
  • Like
Reactions: Sock Tucker

·
Premium Member
Joined
·
845 Posts
Did you ever find out what was causing this? I have the same issue. thanks
There are several recent posts on this subject (some by me and Jason) and basically the Maserati HomeLink system is less than reliable. I have reverted to clipping the garage door remote to the front of the door pocket and it works every time.
 
  • Like
Reactions: Sock Tucker

·
Registered
Joined
·
2 Posts
I did some searching and didn't see anything similar, so figured I'd see if anyone else had this problem.


2018 GT.. I programmed the Homelink and it worked for a bit, but now it's not working. I get 0 lights from pushing the buttons. I've also noticed that neither of the lights in the vanity mirrors work either. Presuming it may be a fuse issue, but couldn't locate the fuse in the manual. I will be taking her in for the Airbag recall, but figured I'd ask here ahead of time. No other electrical issues that I can see, and I did have her on a tender recently.


TIA!
 

·
Registered
Joined
·
1 Posts
I did some searching and didn't see anything similar, so figured I'd see if anyone else had this problem.


2018 GT.. I programmed the Homelink and it worked for a bit, but now it's not working. I get 0 lights from pushing the buttons. I've also noticed that neither of the lights in the vanity mirrors work either. Presuming it may be a fuse issue, but couldn't locate the fuse in the manual. I will be taking her in for the Airbag recall, but figured I'd ask here ahead of time. No other electrical issues that I can see, and I did have her on a tender recently.


TIA!
Did you ever figure this out?? Same issues on my 2014 GTC Sport!
 

·
Registered
2012 GTC Nero/Sabbia
Joined
·
555 Posts

·
Registered
Joined
·
5 Posts
Hi Lam,

I never found the Passenger Fusebox. I only checked the driver fuses box under the steering wheels. Can you show me an image where this fuse box located at? I was looking for it under the passenger foot spot but didn’t see any fuse box.

thanks for replying
 
1 - 14 of 14 Posts
Top