Maserati Forum banner
1 - 20 of 22 Posts

Registered
Joined
44 Posts
Discussion Starter · #1 ·
I have been with problems with my module after wash my engine! This been already 4 months without solution.
Send the unit to MODULE REPAIR IN LOS ANGELS THE GUY JUST F*** with it.
Now I need I new module!
Bought one on eBay but different plug connector.
Having hard time to find exactly like my.
Notice that modules from QUATTROPPORTE 2005 up looks exactly the same.
Does anybody know if I order one of those I鈥檒l will solve my problem?? If not
Does anybody has or know someone that has this module?
I appreciate any help!
Pics before and after the job! How can someone weld hybrid modules like that??? 馃あ馃が馃槨

Bag Automotive design Gadget Gas Automotive exterior
Product Rectangle Mesh Wood Gas
Gas Cooking Bumper Electronic instrument Kitchen appliance
Gas Cooking Bumper Electronic instrument Kitchen appliance
 

Registered
Joined
44 Posts
Discussion Starter · #3 · (Edited)

Registered
Joined
944 Posts
I have been with problems with my module after wash my engine! This been already 4 months without solution.
Send the unit to MODULE REPAIR IN LOS ANGELS THE GUY JUST F*** with it.
Now I need I new module!
Bought one on eBay but different plug connector.
Having hard time to find exactly like my.
Notice that modules from QUATTROPPORTE 2005 up looks exactly the same.
Does anybody know if I order one of those I鈥檒l will solve my problem?? If not
Does anybody has or know someone that has this module?
I appreciate any help!
Pics before and after the job! How can someone weld hybrid modules like that??? 馃あ馃が馃槨

View attachment 139685 View attachment 139686 View attachment 139687 View attachment 139687
I can't rememeber what the proper name of those circuit boards is, but they cannot be repaired. Fiat group used that manufacturing on a bunch of their cars in that period and once they go they're done.
 

Registered
Joined
44 Posts
Discussion Starter · #7 ·
I can't rememeber what the proper name of those circuit boards is, but they cannot be repaired. Fiat group used that manufacturing on a bunch of their cars in that period and once they go they're done.
As far that I know those module are Hybrid!!
When you weld one line you screw up with 3鈥
I don鈥檛 know how this guy can say he repairs. Those modules are at many Brands..
 
Joined
6,069 Posts
These rebuild folks don't really rebuild dick..They take a common problem on a module and then repair that part..If that fixes it then all is good, but if it doesn't they generally give your money back and say the unit is not repairable...They kinda play the odds here..The can't really test the module since they don't have a network to plug into since they don't have a vehicle..Jason
 
  • Like
Reactions: Rc2211

Registered
Joined
84 Posts
I would try to find one off a M138...The hardware can be the same on a M139, but the software maybe different..Jason
Hi Jason, it鈥檚 Mark Murphy, 2006 GranSport, 103,000 miles! I get an intermittent (once every 30 miles) ABS and MSP orange warning light. It turns off after a restart. It鈥檚 been doing this for two years so I just live with it. Maserati of Atlanta cannot find any faults. Should I work with Module Repair Pro ($99 exchange) ?
 
Joined
6,069 Posts
Hey Mark, why are you taking a 4200 to the dealer? I would probably get another module as the rebuilders are limited on what they can repair...Jason
 

Registered
Joined
84 Posts
Jason, I prefer to take the car to YOU for serious matters and serious repairs. Maserati of Atlanta is closer to my house and I thought they could diagnose the issue quickly. I will find a replacement module as you suggested. Thanks !
 

Registered
Joined
84 Posts
Thanks again to Jason "The Maestro" !
He suggested I replace the ABS Module, so last night I tried to remove and inspect JUST the black plastic Bosch Module (not the entire ABS Pump and Brake Lines). Frankly, removing the Module is difficult because there are several small "pistons" that protrude from the Pump Housing and the Module must clear the pistons to remove...I stopped and simply inspected and cleaned the connector with dry, clean, compressed air from a can of electronics duster. I connected and disconnected the multi-pin several times to "clean" the connections. Reassembled.
Drove the car 75 miles today with NO ABS or MPS Warning Lights. (Previously, the lights would come on every 30 miles or so). I cannot say it is a permanent fix, but so far it's working!
 

Attachments

Registered
Joined
44 Posts
Discussion Starter · #14 ·
Honestly, you fixed that possibly...Not me...I told you the module maybe bad...J
Jason , I bought one module from QUATTROPPORTE because I couldn鈥檛 find the from the coupe. I took to a local shop. He mention that needs to the calibration on the steering wheel sensor. Do you know if this info is accurate? Tks
 

Registered
Joined
171 Posts
I think I may be the one who recommended the guy in L.A. to you.
Mine had a small crack in the solder that he fixed a few years back and has been perfect ever since. I have recommended him to a few other people who were also completely satisfied, so I'm sorry it didnt work for you.
Are you certain that its the ABS and not a wheel "speed sensor"?
If you visited this guy's shop you would have seen ABS units from many different car makers so this is NOT one of those Maserati-only issues. Audi's are famous for the problem.
 

Registered
Joined
44 Posts
Discussion Starter · #18 ·
I think I may be the one who recommended the guy in L.A. to you.
Mine had a small crack in the solder that he fixed a few years back and has been perfect ever since. I have recommended him to a few other people who were also completely satisfied, so I'm sorry it didnt work for you.
Are you certain that its the ABS and not a wheel "speed sensor"?
If you visited this guy's shop you would have seen ABS units from many different car makers so this is NOT one of those Maserati-only issues. Audi's are famous for the problem.
Its's allright! As Jason said before ( These rebuild folks don't really rebuild dick..They take a common problem on a module and then repair that part..If that fixes it then all is good, but if it doesn't they generally give your money back and say the unit is not repairable...They kinda play the odds here..The can't really test the module since they don't have a network to plug into since they don't have a vehicle..Jason ). This guy just screw up with my module and didnt have the capacity to assume or tell me my module is not reparable. He hold the module ask for money, cashier check only. and mention the service the I bought at ebay was cheap 99,00 and in order to send the module back I had to pay 150,00 to send me back a bad module. Horrible service and custumer service. I dont reccomend to anyone. (MODULE REPAIR PRO)
 
Joined
6,069 Posts
I did kinda warn you about that, see post #4..The network on a M138 car and a M139 is pretty different as in the fact a M138 doesn't really have much of one...Plus a M139 can have two different network structures...Not to go full auto nerd on you, but you have a protocol or language the module speaks...They have to be the same to make it all work..Jason
 
1 - 20 of 22 Posts
Top