Maserati Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
233 Posts
Discussion Starter · #1 ·
So I was driving today and got some spray off the car in front of me, select the wipers and they DONT WORK. Turned car off and back on, but to no avail. I have no idea where the fuse box is or where to look next...any help would be greatly appreciated. This is something I have not heard of happening yet. And they were working fine 2 days ago. No idea.

Jon
 

·
Registered
Joined
·
233 Posts
Discussion Starter · #2 ·
No one has the owners manual to say which fuse it is at least? please?
 

·
Registered
Joined
·
635 Posts
Windshield Wiper fuse is located under the floor mat on the passenger side. Lower the cover, look on the far right (there are 4 boxes, you want the taller of the 4). Its fuse #37 (a 25 amp white color). Its 5 rows down from the top, 2nd from the right.
 

·
Registered
Joined
·
233 Posts
Discussion Starter · #4 ·
thanks...ill check...after that...the motor?
 

·
Registered
Joined
·
859 Posts
Maybe?

Try reseting everything from the battery cutoff switch in the trunk.
Good luck.
 

·
Registered
Joined
·
233 Posts
Discussion Starter · #6 ·
Well, I reset the battery, no luck, then checked the fuses, none were burnt out, I guess it's time to go to the dealer but I am going out of town for business today and am not going to get to mess with it til I return. I really have no idea what to do now or even where to look for a loose wire or anything. The sprayers still work from the wiper stalk on the wheel but when selecting wipers (in any setting), nothing. If anyone else has any ideas I still have a few hours before I leave. I really hate to take it to the dealer because I know it will probably cost a fortune.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top