Maserati Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter #1
This morning everything was fine, and I parked the car at the airport for the day. When I came back the speakes weren't working. no sound at all. the radio looks like it's tuning OK. the only other odd thing was that Boomerang Tracking called me to ask if everything was OK cause they got an error message from the car or something. Any ideas?

thanks in advance
 

·
Registered
Joined
·
835 Posts
Nevinsimon said:
This morning everything was fine, and I parked the car at the airport for the day. When I came back the speakes weren't working. no sound at all. the radio looks like it's tuning OK. the only other odd thing was that Boomerang Tracking called me to ask if everything was OK cause they got an error message from the car or something. Any ideas?

thanks in advance
perhaps one of the speakers blew, due to sudden surge of current. i would check the pasenger front speaker first.
 

·
Registered
Joined
·
40 Posts
Discussion Starter #4
Thanks for the replies. I turned off the car, turned off the battery switch, restarted and then everything seemed to work.
 

·
Registered
Joined
·
255 Posts
Yes - I find that a quick "reboot" using the battery on/off switch usually clears any niggles with the audio electronics!
 

·
Registered
Joined
·
187 Posts
My 03 coupe has been in Maserati three times for the same problem. usually the speakers will automatically fade all right, or all left and within 10 seconds the system shuts off till I turn the car off. It is typical driving 20 minutes or more. They are going to fully replace the Nav, and amp next week. I will let you know how it goes. Typical italian race car bs. maybe thats why ferraris come with just a no thrills reciever, they have learned.
 
1 - 8 of 8 Posts
Top