Maserati Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
103 Posts
Discussion Starter #1
My 2011 GT has an intermittent problem with the drivers side heated seat. sometimes it comes on even though the dial is at zero , also If i turn it on I dont see it on the display saying its on . any help appreciated. perhaps I can pull a connector to stop the power from going to the heat element . I never use the seat heaters.
 
Joined
·
4,269 Posts
Post should be in Granturismo section...Sounds like the seat module is acting up....Remove the driver's seat and just unplug the elements..Remember you have two...One in the lower section and one in the upper part of the seat.. The wires going to the element will be a little bit larger diameter then the rest....Jason
 

·
Registered
Joined
·
103 Posts
Discussion Starter #4
I took the seat off and I disconnected two grey connectors but then the seat did not operate . so they were not the correct ones , then there were others marked left right I did not want to start messing with them . can you tell me the color of the connectors. I noticed there was an orange connector on the front left side of the seat that was disconnected. is that for a side airbag ?
 
Joined
·
4,269 Posts
Look in your owners manual and see if there is a fuse for both front seat heaters...That maybe an easier way to do it...Jason
 

·
Registered
Joined
·
103 Posts
Discussion Starter #6
i saw one for the front left seat heater I pulled it , we shall see thanks again
 

·
Registered
Joined
·
1,576 Posts
Nevermind the update...
I popped the F52 fuse, driver's side seat heater, from the fuses under the steering wheel and it's a done deal!!!
 

·
Registered
Joined
·
103 Posts
Discussion Starter #9
thats what I did, however it may be a battery problem too, because if your battery is not 100 percent things can go wrong.
 

·
Registered
Joined
·
1,576 Posts
Batt. is only about 4 months old in my case....probably just a bad switch that i will change out later.
 
1 - 10 of 10 Posts
Top