Maserati Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1 (Edited)
It's about 20,000km 2010 Grancabrio model, Suddenly the automatic gear doesn't work when It's fully accelerated.

It worked perfectly when I carefully accelerate it then. but when I just fully accelerate it then it doesn't change to gear 2 stay gear 1 with High RPM.

I think It's pretty weird because It's okay with Sports mode and Ice mode. Just only normal auto mode then gear doesn't work at all.

So I had to manually use the paddle shift to change the gear. It works fine.


Anyone has had a problem like this before?



Pretty weird. I have been driving a car once for 2 months.
 

·
Premium Member
2013 Maserati GranTurismo Sport
Joined
·
371 Posts
Sounds like a bad/stuck solenoid. I would get that looked at immediately.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
Sounds like a bad/stuck solenoid. I would get that looked at immediately.
Thanks for your information, Recently the rear brake light turns on after turning off the ca so I had to push the brake pad to turn it off the brake light.
I think the brake sensor has some problem now and it could make this happens.

I should check the solenoid and the brake sensor and let you know
 

·
Super Moderator
Joined
·
4,677 Posts
Check your brake light switch first. Simple, cheap, prone to failure.

C
 

·
Super Moderator
Joined
·
4,677 Posts
You mean "Brake light sensor?" or Is there any switch for the brake?

Thanks
As ever, Jason is correct. However I mean specifically the switch on the brake pedal.

C
 
1 - 7 of 7 Posts
Top