Maserati Forum banner
1 - 17 of 17 Posts

· Registered
Joined
·
150 Posts
Discussion Starter · #1 · (Edited)
So, I got some goodies in! Any guess as to what it/they are!?
Packing materials Shipping box Wood Rectangle Packaging and labeling

Good guess! I put it in the title!

I didn't get many shots of the install, but it is very easy...
Plant Automotive tire Automotive lighting Motor vehicle Automotive design

Can you guess which one the new one is?

It goes here (dead center of the photo):
Light Motor vehicle Black Automotive tire Tread


I also replaced the Fan resistor because I saw that it looked horrible when I last changed the oil:
Motor vehicle Toy Automotive tire Automotive design Gas

I took it for a shake down run and noticed a big difference (when the A/C is off)... my engine fan isn't blaring

I also installed a back-up camera and LED license plate lights:
Car Motor vehicle Vehicle Automotive lighting Hood


I "pre-ran" the wires when I first installed the Android head unit, then a bit more when I removed the rear seats to install the reupholstered headliner I showed in another post.
Motor vehicle Hood Automotive exterior Trunk Automotive design


Last but not least, a new battery...
Electronic instrument Gadget Audio equipment Bumper Gas


Viola! I wanted a DH7, but H6 is all they had.
Bumper Automotive exterior Motor vehicle Trunk Automotive lighting


If anyone ever has to swap their secondary air pump, let me know, its any easy job
 

· Registered
Joined
·
150 Posts
Discussion Starter · #3 ·
Nice work. How did you know your air pump needed replacement?
Thanks!
I got a CEL and looked the code up, Secondary Air issue. Took a look at the blower while I was changing the oil, and it looked like that… so process of elimination. There are other issues that could cause that CEL, but because this looked visibly beat, I decided to try to replace it first.
 

· Registered
Joined
·
150 Posts
Discussion Starter · #5 ·
Thanks. It looked like it had some external physical damage in your photo. Mine whistles when I start up the car cold. Wonder if that is normal...
That is exactly the signal that also led me to think that it was the red herring. That whistle gets much louder over time. The pump sucks in water and corrodes the bearings in the pump. After a while it will become very embarrassing to start the car. Then one day it will go away, and a CEL will come up.
 

· Registered
Joined
·
2 Posts
Thanks for the info on those parts, do you have a part # for that secondary pump and would you be willing to let us know where you bought it? My mechanic is telling me they are $1700 new OEM, and that sounds crazy to me. Ebay has them for MUCH less, not sure which one is for my 2013 GT MC. Thanks very much for your time!
 

· Registered
Joined
·
150 Posts
Discussion Starter · #10 ·
Thanks for the info on those parts, do you have a part # for that secondary pump and would you be willing to let us know where you bought it? My mechanic is telling me they are $1700 new OEM, and that sounds crazy to me. Ebay has them for MUCH less, not sure which one is for my 2013 GT MC. Thanks very much for your time!
Scuderia Parts is a great outlet. Slow shipping though.
Font Parallel Rectangle Pattern Number
 

· Registered
Joined
·
841 Posts
There are 2 power supplies to the fans. The first, thru the resistor, for low speed, the second for high speed. I made up a male-male spade jumper to bypass the resistor if it should burn out. When it does burn out, the fans only run on high speed, and come on at about 205 degF. With the jumper the fans will come on at 190degF but high speed only. Keep the jumper in the tool kit for emergencies.
 

· Registered
Joined
·
150 Posts
Discussion Starter · #13 ·
There are 2 power supplies to the fans. The first, thru the resistor, for low speed, the second for high speed. I made up a male-male spade jumper to bypass the resistor if it should burn out. When it does burn out, the fans only run on high speed, and come on at about 205 degF. With the jumper the fans will come on at 190degF but high speed only. Keep the jumper in the tool kit for emergencies.
The sound level of the fans is the problem for me… they are loud and embarrassing in my opinion… going through drive throughs was a chore for me
 

· Registered
Joined
·
150 Posts
Discussion Starter · #15 ·
So does the backup camera go to one of the replacement head units or ????
What I really need is a front camera to protect my carbon fiber spoiler from high curbs.
Yes, I have an aftermarket head unit.
It also has a setting that activates the front sensors at speeds under 15mph, which helps to avoid from in scrapes. Sliplo scrape guards are a must as well.
 

· Super Moderator
Joined
·
5,602 Posts
There are 2 power supplies to the fans. The first, thru the resistor, for low speed, the second for high speed. I made up a male-male spade jumper to bypass the resistor if it should burn out. When it does burn out, the fans only run on high speed, and come on at about 205 degF. With the jumper the fans will come on at 190degF but high speed only. Keep the jumper in the tool kit for emergencies.
If you're down there with a jumper, why not just put in another resistor? They cost pennies (at least here) shared with a load of Alfas

C
 
1 - 17 of 17 Posts
Top