Maserati Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 · (Edited)
Faulty air temp sensor? Faulty Blower? Faulty Maserati?

I have a 2006 GranSport. The AC was working fine this summer. 3 days ago we had a 90 degree day here in NJ and the AC wouldn't work, that is the blower wouldn't work. The car was parked in the sun for 15 minutes or so.

I've had AC/ heating problems 4 times since i bought the car new. And each time the dealer replaced parts. Once for the thermostat (blower worked, no cool air) and the other times related to the blower.

But just yesterday, i started the car which had been garaged and the AC blower works now.

Any ideas as to why this happened? Does my car have a lemon AC/heating unit? What could be replaced or upgraded to prevent this?

Thanks.
 

·
Registered
Joined
·
141 Posts
Minotto, It sounds like a bad connection at your blower motor connector.
I have seen a few of these where the motor works hard causing the extra amperes of electricity to overheat the connector. You can check this yourself, the blower motor is located up under the dash on the passenger footwell. Remove the cover and locate the connector near the firewall on the black plastic case and unplug and look inside the connector with a flashlight to see if there is any distortion from the heat. If so, you can probably ( I don't know your level of aptitude) clean and tighten the connectors and refit.
PM me if you need further assistance. Hope this helps, best of luck.
 
1 - 2 of 2 Posts
Top