Maserati Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi All,
The letter 'E' which I understand means errror with the climate control shows on the dash board of my Gran Sport - I have left it into the dealership and they have neve seen the error and dont know how to fix it! they say it is nothing to worry about and to forget about it! I have no intention of forgetting about it and and told them to sort it - has anyone come across this problem before?

Thanks
Phil
 

·
Registered
Joined
·
1,685 Posts
maserati of minneapolis said:
Is it an E in the center display, like under the gear # where the outside temperature normally is?

If so it could be an error with the outside temp sensor which is on the bottom of the driver's side mirror.

see pics.
Or is it E like you're pointing East? :D
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Thanks maserati of minneapolis - that is exactly where the 'E' is showing - I will mention your remarks to the useless dealership the car is with.
Thanks again for the reply.
Phil
 

·
Registered
Joined
·
824 Posts
This has recently shown on my car (twice). Told dealer.

However, once I stopped the car and restarted it went away.

Once it shows, climate control goes into "lame default mildly warm defrost" mode. FYI.

Mine will be looked at next time it is at the dealer.
 

·
Registered
Joined
·
660 Posts
The E means the climate control actuator is jammed / faulty. A circa 70 U$ spare which will need 4 to 5 hours labor (ouch) as you need to remove the complete front dash to replace it.

Pot luck. It is not a critical component warning, unless you're freezing into the car (or otherwise).

Hope this helps,

Ed
 

·
Registered
Joined
·
8 Posts
Thanks Ed - that sounds about right,hense why the dealership did not want to fix it :mad:
The car is only 9 months old,so it should be covered under warranty - I hope!
Cheers
Phil
 

·
Registered
Joined
·
173 Posts
pjs32 said:
Thanks Ed - that sounds about right,hense why the dealership did not want to fix it :mad:
The car is only 9 months old,so it should be covered under warranty - I hope!
Cheers
Phil
Yes, it should be under warranty. I have that Error a while ago. When that happened, there is no heat in my car. And my dealer changed the actuator under the warranty with no problem.
You've got to yell at your dealer.

pganmol
 
1 - 9 of 9 Posts
Top