Maserati Forum banner

21 - 28 of 28 Posts

·
Registered
Joined
·
276 Posts
Ha I wear those as my winter running shoes. I have a couple pairs of the 5 fingers, love those shoes (if that's what they're called)
 

·
Registered
Joined
·
3,309 Posts
Discussion Starter #22
Update

Thread updated for DIY Coolant Flush
 

·
Registered
Joined
·
44 Posts
Torque Specifications

Does anyone have a list of fastener torque specifications for 2006 GranSport Spyder (I assume 4200's may be same) for various fluid change drain and filler plugs and other relevant fasteners that may need to be removed. - thanks
 

·
Registered
Joined
·
27 Posts
Could someone kindly re-post the engine intake air filter change DIY guide for the 4200 Coupe/Spyder?

It looks like the link to the Adobe website died. I'll be happy to host the document on my dropbox or something for all to enjoy.

-The engine on my 2004 Coupe spit up some excess oil (probably my fault for slightly overfilling it) and I cleaned out the MAF and throttle body. The check light is off now, but I think it might be worth replacing the air filter just for good measure.
 

·
Registered
Joined
·
2 Posts
Gran Sport air filter change - repost

The link for the 4200 air filter change is a nightmare - I spent over two hours joining adobe, downloading, creating passwords, reformatting, converting --- all for nothing.

This is my first post to the forum - looking forward to a better introduction in my next couple of posts. Currently frustrated

Thanks in advance to whomever reposts the air filter change process for this newbie:smile2:
 

·
Registered
Joined
·
5 Posts
Maybe someone can help me I have a 2006 Maserati quattroporte that issue I had when the car is cold it would drive fine and shift fine soon as it would warm up it would pop me out from third gear to neutral and sometimes from 5th gear so I would have to manually shift and skip third someone told me that actuators may be sticking so I have another car for parts we swap the whole transmission with actuators and pump now The pump goes on the car goes in reverse but not drive I try to bleed the actuator block on top does the bolt I think it's 17 mm and the quick disconnect bleeder every time the pump pumps and builds up the pressure when I unscrew the top bolt on the actuator block with all the lines I get a lot of air coming out but no fluid the reservoir is full if someone can help me what is the proper bleeding procedure on F1 transmission also if I open that quick disconnect bleeder on the line and the top bleeder at the same time and let the pump prime transmission Failure light goes on the dash and it will not go in reverse or drive after I close the bleeders it will go in reverse but not drive or first gear please help
 
21 - 28 of 28 Posts
Top