Maserati Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
So we recently picked up a black Coupé and so far so good. The car came with an integrated iPod cable, but for whatever reason it’s not working at all. The cable charges the iPod, but will not play anything. While trying to figure this all out, we pulled out the rear CD Changer to check all the connections (what a PITA). In the process of testing everything, we plugged the CD Changer back to its factory setup and found that wasn’t working either. When we put a CD in it the physical player knows there’s a CD in as specific slot lights up green, but the display on the Info Centre does not register that there is a disc, furthermore, it just says “CD init” without change. To make matters worse the changer does not eject CD’s from any slot.

My question is do you think the CD changer is busted? If so, does that explain why the iPod cable doesn’t play? Finally, where could one pick up a new changer (non-dealer supply preferably)?

Thanks for any help.
 

·
Registered
Joined
·
104 Posts
almost sounds like the plug that goes into the back of the NIT is not in. If you are using an dennon ice link ipod adapter, it "replaces" the CD cable on the back of the NIT. if you are using the ipod adapter sold on ebay, it "piggybacks" with the existing CD plug on the back of the NIT.

I think I have one of each type lying around if you are interested (for a nominal fee of course!) since I have gone "loudlink" and don't need either.

JJ
 
1 - 2 of 2 Posts
Top