Maserati Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hi, I've got a beautiful 2007 QP with ~35K miles.

When it starts it makes a terrible rattling noise which tends to mostly go away after a while.

Some reliable mechanics have looked at it and told me it's the intake variables that are failing.

Apparently some cylinders are not firing due to this, but the car can still go as fast as I want when I want it to.

Any suggestions on a South Florida facility that can do a good job repairing this problem without requiring a mortgage?
 

·
Registered
Joined
·
31 Posts
HI MAX, are you close to Miami ? on parts alone its about 3k , that's variators, solenoids, valve cover gasket, front seal gasket and seal , and sending out the cam caps to get the check valve installed ..
 

·
Registered
Joined
·
31 Posts
mr. sinister first make sure proper oil level , and what weight oil are you using ?
then if that is ok , try to unplug the connector for the cam adjustment solenoid on both sides
they have 2 taps that hold then in place , use a small paper clip to pry out slightly .. then re-check with cold engine , let me know if that works ..
 

·
Registered
Joined
·
51 Posts
then if that is ok , try to unplug the connector for the cam adjustment solenoid on both sides
they have 2 taps that hold then in place , use a small paper clip to pry out slightly .. then re-check with cold engine , let me know if that works ..
Thank you for the information. Am I leaving them unplugged to re-check?
 
1 - 5 of 5 Posts
Top