Maserati Forum banner

21 - 39 of 39 Posts

·
Registered
Joined
·
32 Posts
Follow-up to my clock offset problems. I bought a used clock off eBay a few months ago. The replacement clock has older hardware and software codes compared to the original "flaky" clock. But everything is working fine now--even Timebase seems to keep things in tune with the "new," older clock. A couple weeks ago this new clock with Timebase ON did one of the resets where it spun around a whole bunch of times before finally settling on the correct time.

HW-flaky clock: 03.02
HW-working clock: 03.01

SW-flaky clock: 03.12
SW-working clock: 03.11

Someone mentioned previously that an update to the clock improved things. Anyone know what the hardware/software codes were for the update?
 

·
Registered
Joined
·
18 Posts
Easy to sync. Hold the two interior light buttons on the roof for 15 seconds. The lights will start to flash. Left button then does hours, right button does minutes.

Hope that helps.
This worked for me, the lights flash intermittently left-right, and buttons adjust the clock hands. Adjustment sounds very mechanical :)).
 

·
Registered
Joined
·
32 Posts
Boomer, I never had the "beep" problem with my clock but I wonder if it could be related to GPS time setting. Is "Timebase" box checked when this happens? It would make sense that you could not adjust time if GPS was automatically setting it but that isn't how it works on a 2006.
 

·
Registered
Joined
·
31 Posts
FIX FOR ANALOG CLOCK .
OK, first on the dome light assembly , hold both outer buttons ( the ones that turn on the small lights) . hold and keep pressed until both side lights start to blink ( may take 2 minutes holding ).. release and used the buttons for the side lights to move forward or backwards , once done turn the dome light on and off ..
 

·
Registered
Joined
·
6 Posts
FIX FOR ANALOG CLOCK .
OK, first on the dome light assembly , hold both outer buttons ( the ones that turn on the small lights) . hold and keep pressed until both side lights start to blink ( may take 2 minutes holding ).. release and used the buttons for the side lights to move forward or backwards , once done turn the dome light on and off ..
Dumb question, tried doing this....the side buttons you refer to are the same ones I pushed and made flash? I got them to flash and tried using the same buttons to change the time but did not do anything. Thanks!
 

·
Premium Member
Joined
·
894 Posts
What year is your QP5? The cited process doesn't work on my 2009. For mine, there is a separate setting in the Infotainment system's System section. Trouble for me was the correct time when entered into Infotainment read a minute slow on the analog clock. So my workaround was to enter not correct time but a minute fast.
KTBD
 

·
Registered
Joined
·
6 Posts
What year is your QP5? The cited process doesn't work on my 2009. For mine, there is a separate setting in the Infotainment system's System section. Trouble for me was the correct time when entered into Infotainment read a minute slow on the analog clock. So my workaround was to enter not correct time but a minute fast.
KTBD
Mine is a 2008. I set the clock in the infotainment, but that did not set the analog.
 

·
Registered
Joined
·
45 Posts
Dumb question, tried doing this....the side buttons you refer to are the same ones I pushed and made flash? I got them to flash and tried using the same buttons to change the time but did not do anything. Thanks!
Hi, just to confirm, I also have a 2008 QP V (GT S), and the procedure with the interior light buttons on the roof worked for mine to synchronize the clocks (just setting the time in the digital display did not work however).

Best, Alex
 

·
Registered
Joined
·
213 Posts
I have just changed the battery on my 04 QP and I cant stop the analogue clock speeding around. I have reset the time and that has registered on the digital but not the analogue.

Any ideas as I don't want a flat battery again!
Did you try disconnecting the battery and leave it disconnected for a long while, and then reconnect it?

When I had to do that for other reasons, and left it disconnected over night, when I reconnected the battery, both clocks reset to 12:00.

Mine eventually loses minutes compared to the digital, and it might be that satellite thing. I'll look into that.
 

·
Registered
Joined
·
32 Posts
My 2nd clock died in my 2006 QP a month ago. I'm astonished at how often I look at this clock for the time. I thought I could live with it not working but it is driving me crazy. Just bought and installed clock #3 off eBay. Fingers crossed that this one lasts more than a couple of years. Is there anyone who fixes these things?
 

Attachments

·
Premium Member
Joined
·
1,495 Posts
Yeah I don't know, it does seem that the analog clocks are troublesome. Mine works mostly, but spins around to reset itself now and then because it gets "stuck" at particular times. As soon as it gets out of sync, it goes haywire trying to reset itself, which it eventually succeeds at doing.
 

·
Registered
Joined
·
22 Posts
I have just changed the battery on my 04 QP and I cant stop the analogue clock speeding around. I have reset the time and that has registered on the digital but not the analogue.

Any ideas as I don't want a flat battery again!
HI PAUL,

appreciate this post was several years back.
However did you solve the speeding clock issue?
I have similar problem after recharging my battery.
First I disconnected the earth and had battery on mains smart charger.
Battery appears in good nick and fully recharged.
Then reconnected and left on solar panel trickle charger with a controller.
This morning I started car fine noticed clock was spinning around like it was trying to reset.
Resett the digital time ok and entered code no probs.
all the way to work this morning clock kept on spinning.
Disconnected battery in carpark for the day.
 

·
Registered
Joined
·
349 Posts
Yeah I don't know, it does seem that the analog clocks are troublesome. Mine works mostly, but spins around to reset itself now and then because it gets "stuck" at particular times. As soon as it gets out of sync, it goes haywire trying to reset itself, which it eventually succeeds at doing.
Sean, those buttons near the moonroof which suppose to control analog clock as well, are they doing anything related to the clock in your QP? They seems to do nothing on my QP. Should I disable the Timebase/GPS sync first?
Thank you very much.
 

·
Premium Member
Joined
·
1,495 Posts
Sean, those buttons near the moonroof which suppose to control analog clock as well, are they doing anything related to the clock in your QP? They seems to do nothing on my QP. Should I disable the Timebase/GPS sync first?
Thank you very much.
I looked but I don't have any such buttons on the roof that pertain to the clock. The roof buttons only do stuff for the communications system and the TPMS calibration.
 

·
Registered
Joined
·
349 Posts
I looked but I don't have any such buttons on the roof that pertain to the clock. The roof buttons only do stuff for the communications system and the TPMS calibration.
Thank you very much and no worries, Sean. My analog seems just 2 seconds faster than digital, so not a big deal.
 
21 - 39 of 39 Posts
Top