Maserati Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter · #1 ·
Cruising on the highway last night, had my GS with cruise control on had to brake for someone so cruise disengages, I hit the RCL to restore and the cruise light goes out??? then i have to change lanes and my indicators no longer work????? My hazards work fine, all lights work fine....what gives? fuse or relay? Any ideas on how I can or should approach this? Thank you.
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #2 ·
well its not the fuses, they are all good. Any mechanics? anyone ever have anything like this?
 

·
Registered
Joined
·
1,067 Posts
Confused Computer...

Hit the battery disconnect for about 2 minutes and try it again...
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #4 · (Edited)
battery disconnect???

ok found the switch, turned it off let sit for 5 mins, turned back on and.....nothing still, maybe more than the computer..thanks for the suggestion though I will take any @ this point
 

·
Registered
Joined
·
255 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter · #6 ·
Hoooray!!

Thanks for he thread barbuckle, it was not the exact same problem but it was fuse related, #32 in the diagram which controls the cruise control, etc...duuuh should have checked that this morn too, was soooo convinced it was the indicators fault! Thanks again to you guys who suggested stuff! Really appreciate it!
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top