Maserati Forum banner
1 - 20 of 22 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hello!

New member here. Recently purchased a 2014 GranTurismo and during the pre-delivery check the dealer noticed the check tail light indicator even though all the lights appear to work as they should. The dealer has been trying to fix this issue before they deliver the car. They've been working on it for almost 6 weeks now. It's a Maserati dealer so they are having to check with Maserati in Italy after every attempt to resolve the issue which is one of the biggest reasons for the delays. So far they've replaced bulbs, checked wires, replaced entire front driver's headlight and today replaced and programmed the body control computer. The issue is still there. Now they are waiting again on tech support in Italy.

Any thoughts on what could be done next?
 

·
Premium Member
2013 GTS Coupe
Joined
·
4,910 Posts
Ugh, just reading this is frustrating enough, I can only imagine what a pain it must be to experience it.. Six weeks and neither the dealer or Maserati in Italy can figure out what’s causing it ? At least you won’t have to pay for any of this, correct ?

In a slightly similar case my license plate lights alert icon comes on from time to time, even when the lights are working .. I checked the wiring, cleaned all the contacts, replaced the bulbs ( even though they didn’t need it ) and the light still comes on once in a while . So I’m interested to find out what causes your car‘s symptoms even though it’s not exactly the same as mine, there might be some commonality..
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 · (Edited)
Yeah, definitely quite frustrating but the dealer has been quite good through all of this. I’m in a northern climate so the days left to drive it are diminishing. Haven’t had to pay anything on the repairs which is great! What they’ve had to do sounds quite expensive.

In a slightly similar case my license plate lights alert icon comes on from time to time, even when the lights are working .. I checked the wiring, cleaned all the contacts, replaced the bulbs ( even though they didn’t need it ) and the light still comes on once in a while . So I’m interested to find out what causes your car‘s symptoms even though it’s not exactly the same as mine, there might be some commonality..
I actually read your thread and messaged the service manager yesterday asking if he had checked into the license plate lights. I’m almost certain they would have but I know that would have been the last place I would check. I was going to ask if your issue had been resolved so I’ll keep you updated on the resolution here!

While talking to the service manager he mentioned that the light only comes on for a little while and then goes out. So may be a similar issue!
 
Joined
·
7,622 Posts
You know you are actually irritating the service dept.. right? The last thing they want to hear is that you " read on the internet"...They have a full service dept. and access to the people that built the automobile so they are gonna be your best bet for repair at this point..Jason
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #5 · (Edited)
You know you are actually irritating the service dept.. right? The last thing they want to hear is that you " read on the internet"...They have a full service dept. and access to the people that built the automobile so they are gonna be your best bet for repair at this point..Jason
I get your point for sure.

Not sure if it’s irritating them though, it was the first message I had sent in regards to any thoughts I had on the issue in the past 6 weeks. Also prefaced it with thanking them for everything they are doing and acknowledging that they almost certainly had already checked the plate lights. The message was essentially that I thought I’d mention it only because I know I wouldn’t have thought to check there and someone else had a similar issue.
The GSM and Service Manager made several comments to me in the past that they’ve never seen anything like this before.
 
Joined
·
7,622 Posts
I don't think that is a Maserati thing..That is all modern cars...They are all filled with modules and ECUs and they don't always work right all the time...I constantly hear of cars that the blue tooth won't connect, the tailgate won't open sometimes, etc...That is just the modern automobile...J
 

·
Registered
Joined
·
108 Posts
I don't think that is a Maserati thing..That is all modern cars...They are all filled with modules and ECUs and they don't always work right all the time...I constantly hear of cars that the blue tooth won't connect, the tailgate won't open sometimes, etc...That is just the modern automobile...J
Good point, the 2017 Mercedes pile of crap sedan I leased (before I decided to come back to the sexy Italians) was always flickering the electronics on and off or the stupid Nav screen would randomly shut off and slowly reboot back on. I was taking it back to the dealership damn near every 90 days for some sort of software reprogramming, and though this was "covered under warranty" Mercedes (corporate) would fuss.
 

·
Registered
Joined
·
26 Posts
Hello!

New member here. Recently purchased a 2014 GranTurismo and during the pre-delivery check the dealer noticed the check tail light indicator even though all the lights appear to work as they should. The dealer has been trying to fix this issue before they deliver the car. They've been working on it for almost 6 weeks now. It's a Maserati dealer so they are having to check with Maserati in Italy after every attempt to resolve the issue which is one of the biggest reasons for the delays. So far they've replaced bulbs, checked wires, replaced entire front driver's headlight and today replaced and programmed the body control computer. The issue is still there. Now they are waiting again on tech support in Italy.

Any thoughts on what could be done next?
Did they disconnect the battery and reconnect?
 
Joined
·
7,622 Posts
These are professional techs. with dealer training..They are not idiots...The battery unhook thing will only carry you so far..Plus in order to check your wiring and grounds the circuits can't be active so you need to unhook the battery..Plus replacing the body module requires battery disconnection..They have probably had it hooked/unhooked numerous times...Jason
 
  • Like
Reactions: MGT14
Joined
·
7,622 Posts
I'm not sure folks get what a pain in the ass it is to fix stuff like this..It just takes your harness fasteners to be not exactly right on your harness and have it rub on the chassis..The chassis moves as it flexes over the road and eventually will wear through the wire insulation..As the car sits in the shop the car maybe fine during testing because the chassis is not moving...Hopefully, they have it figured out...Jason
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #14 ·
Yep, definitely seems like a huge pain. Add onto that the fact that they also are working directly with the techs in Italy with the time difference as well.
I wish there was an easy one fix fits all for anyone dealing with a similar situation but seems like it is unique to each vehicle. Might be best to check high wear areas like hinge points for wire damage. I’ll report back with what specifically fixes it once I know more. The part they ordered is stuck in Florida due to the hurricane.
 
Joined
·
7,622 Posts
Dealing with Maserati is kinda a joke or Italy for that matter...We do Jaguar, Land Rover, Ferrari and Maserati...I would much rather deal with JLR...They are on their game...The Italians are in their own world..I have a lot of stories about parts ordered and them not really knowing exactly where they were at after like 2 months...They do stuff their own way...J
 
  • Like
Reactions: MGT14

·
Registered
Joined
·
10 Posts
Discussion Starter · #16 · (Edited)
Going on 7.5 weeks now. It’s not clear to me if the drl module did anything. They did identify a power issue going to the module. They did also indicate they were able to get 2 of the 4 side marker lights working. Still not sure what’s going on with the other two lights.
Pretty confusing to me since I was originally told it was just a notice on the dash to check the lights and the lights were actually working. Now it seems that there are actually lights causing a problem. Still not really sure what’s going on.

I get that this is a problem they’ve never seen before but 7.5 weeks seems a bit much. I can only imagine how frustrated the techs must be feeling. At this point the car will get delivered straight into the garage where it will sit till spring. We’re already starting to get snow here.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #19 ·
After just over 8 weeks the vehicle is being delivered tomorrow! From what I’m told there was a damaged or severed wire causing an issue with power to the daytime running lights.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #20 ·
Just got the car today! No warnings on the dash at all!
One issue that was not noticed till delivery is that the none of the steering wheel buttons work. They don’t even light up. Apart for that issue (which they are working to address) the car is amazing! The sound is really incredible.

Wheel Tire Car Vehicle Window
 
1 - 20 of 22 Posts
Top