Maserati Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hi i recently been working on my 85 biturbo E i bought it after beeing sitting for about 3 years i replaced the fule lines,most vaccume hoses, plugs , cleaned the carb an replace fluids ext. it practicaly fired right up but wont run unchoked when its about half choked it will gain rpm but sputter an backfire horibly i havet chekedif i was gettin 2psi off my fule pressure regulator but what could my problem be anny solutiouns. Also my fulepump doesint click off like i herd there supposeto just keeps pumping.
 

·
Registered
Joined
·
88 Posts
Have you tried adjusting the idle while the carb box was removed. Have you verified the timing on it? As far as I know the fuel pumps stay on while the ignition is in the on position.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #4 ·
Thanks i will giver a nouther try tomorow anny clue on what the fuel air screws should be set at i still yeat havent bought a manual :p
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
for my timeing do i jus match up the 2 dots like a normal twin cam setup an how liely would my timeing be off are thay known to slip
 

·
Registered
Joined
·
175 Posts
There should be alignment notches on the block behind the cam wheels and don't forget that the timing belt alone indexes the cams to each other and to the crank so check to make sure all three are aligned. However if the engine ran without backfiring before it was parked a timing issue seems unlikely.

Have you checked the ignition timing?
 
1 - 6 of 6 Posts
Top