Maserati Forum banner

1 - 20 of 32 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
Hello, yesterday I noticed my car was overheating. I was going about 40-45km/h. I had my A/C on as well. I checked if the fans were working, but they weren’t. I have no idea why and how. I check the fuses but they were fine. Next I moved on to relays but I don’t have a diagram of which relay is for the cooling fan. Does someone know where the relay is for the cooling fans? Any solution to this problem? Any help will be appreciated!! Thanks!!
 

·
Registered
Joined
·
1,552 Posts
Hello, yesterday I noticed my car was overheating. I was going about 40-45km/h. I had my A/C on as well. I checked if the fans were working, but they weren’t. I have no idea why and how. I check the fuses but they were fine. Next I moved on to relays but I don’t have a diagram of which relay is for the cooling fan. Does someone know where the relay is for the cooling fans? Any solution to this problem? Any help will be appreciated!! Thanks!!
I have no idea if your 09 is like my 14 but here is my info, maybe it can help :unsure:
My relays, (2) low speed/high speed fans, are on the passenger side underneath the hood up near the firewall...
2 different relay part numbers, 1 is just a newer part
passenger side, near firewall.png
relay locations.png
low speed:high speed relays.png
 

·
Registered
Joined
·
27 Posts
Discussion Starter #3

·
Registered
Joined
·
27 Posts
Discussion Starter #4
Joined
·
4,250 Posts
It won't be any of the relays that size... It is two of the 3 larger ones...Jason
 

·
Registered
Joined
·
1,552 Posts
if you don't have an owner's manual, look it up for your vehicle online, to tell you which ones are for your fan/fans.
 

·
Registered
Joined
·
285 Posts
T15 and T16. Probably only 1 of them are bad. I've replaced the same one twice over the last 6 years. Here is 4.2 and 4.7 diagram.
Screenshot_20200729-192648_Samsung Internet.jpg

Screenshot_20200729-192743_Samsung Internet.jpg
 

·
Registered
Joined
·
27 Posts
Discussion Starter #9 (Edited)
So I took my car to a shop and they checked all the fuses and relays. They are “fine, according to what they see”. They also hooked the fans directly to the battery and the fans turned on no problem. So it can’t be the fan motor. I’m thinking it’s the cooling fan temperature switch if that’s even a thing in my car? Or resistor?
 
Joined
·
4,250 Posts
That isn't much of a diagnosis for a car shop...Just saying...There is no fan temp switch and any shop worth a salt should know that...The engine ECM controls the fan function via an input from the coolant temp sensor...Do the fans come on with the A/C on? Jason
 

·
Registered
Joined
·
1,552 Posts
Replace the fan relays anyway. It's cheap insurance and you would be surprised at how inept people are at testing relays! Just because a relay clicks does not mean it works, and that's how a lot of people test them. It could still be a problem with the relay. It needs to be tested under load/power and then read with a voltmeter to read that power is actually traveling through it properly and that the resistance between the different pins is correct.
 

·
Registered
Joined
·
27 Posts
Discussion Starter #12
Thank you Jason and Timado404 for your replies. The fans do NOT come on even with the A/C on. And I will try to get the relays anyways. But if that doesn't fix it, could it be the resistor?
 
Joined
·
4,250 Posts
Take both old relays out...Turn the relay over..The terminals are marked...Take a small wire and strip both ends...Connect the terminal #30 to the terminal marked #87 based on the how it looks on the button of the relay..You can also google how to jump a relay...One jump will operate the fans at the low speed and the other will run them at the high speed....Jason
 
Joined
·
4,250 Posts
I didn't say that..When you jump the relay you can eliminate the entire power circuit...Now you know that the fuse and the wiring fan etc. are good..I would do what I suggested in my previous post...Jumping off the path for a quick fix doesn't always work out....J
 
  • Like
Reactions: Catmanv2

·
Registered
Joined
·
27 Posts
Discussion Starter #17
Nappa doesn't have 50 amp relays... I live in Saskatchewan, Canada.. I need these relays ASAP. I don't know where to get them. :(
 

·
Registered
Joined
·
1,552 Posts
so you guys think its the relay then?
You need to eliminate the relay as a potential problem, in short, that's what J's suggestion will do. It's the least expensive end of the problem, so you want to make sure you start here but also get it right!
 

·
Registered
Joined
·
27 Posts
Discussion Starter #20
You need to eliminate the relay as a potential problem, in short, that's what J's suggestion will do. It's the least expensive end of the problem, so you want to make sure you start here but also get it right!
does eliminating the relay mean bypassing the relay?
 
1 - 20 of 32 Posts
Top