Maserati Forum - Reply to Topic
Thread: Battery Drain Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Maserati Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
05-22-2019 10:40 PM
[email protected] Enzo`s Atlanta Yeah, it sounds like the alternator is going bad...A battery tender is only needed if you let the car sit a lot...The car is equipped with the best battery charger there is... The alternator...It is more than capable of charging the battery 100%...Jason
05-22-2019 10:32 PM
svandelune
Battery Drain

I have a 2010 Granturismo and have battery issues. I took it into the dealership and they replaced it with the standard Maserati (Fiamm) battery. Everything worked fine for a couple of weeks and then it all started again. While driving all of the electronics went crazy. Once I got home I turned it off and restarted it without any problem but couldn't get it out of park. I let it sit for a while and started it again without any issues except the battery light was lit up. I got on this forum and read some posts and it seemed like a battery maintainer/charger was recommended so I went and bought a battery tender 1.25amp and charged it. It took about 4 days to fully charge which seemed extreme. I drove it for about 10 minutes. I put it back on the charger/maintainer and it started charging again. The battery light is still on and was on while driving even though the battery maintainer/charger said it was fully charged. I am not sure if there is something wrong with the alternator or if something is continually running to drain the battery. Any ideas?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome